Прошерстил кучу статей и мануалов по этому поводу, однако, так и не могу понять, как обойти проблему.
Есть конфигурация микротика:
Код: Выделить всё
/ip address
add address=1.1.1.1/24 interface=ether1 comment="MTS"
add address=2.2.2.2/24 interface=ether2 comment="Avant"
add address=10.0.4.0/24 interface=ether4 comment="LAN"
add address=10.0.5.0/24 interface=ether4 comment="LAN"
/ip route
add check-gateway=ping distance=1 gateway=8.8.8.8 target-scope=30
add check-gateway=ping distance=2 gateway=8.8.4.4 target-scope=30
add check-gateway=ping distance=1 dst-address=8.8.8.8/32 gateway=х.х.х.х
/ip firewall nat
add action=masquerade chain=srcnat comment="MTS" out-interface=ether1
add action=masquerade chain=srcnat comment="Avant" out-interface=ether2
/ip firewall mangle
add action=mark-connection chain=input comment="MTS Input" in-interface=ether1 new-connection-mark="MTS Input"
add action=mark-connection chain=input comment="Avant Input" in-interface=ether2 new-connection-mark="Avant Input"
add action=mark-routing chain=output comment="MTS Output" connection-mark="Tars Input" new-routing-mark="Out MTS"
add action=mark-routing chain=output comment="Avant Output" connection-mark="Avant Input" new-routing-mark="Avant Telecom"
add action=mark-routing chain=prerouting comment="LAN load balancing 2-0" \
dst-address-type=!local in-interface=ether3 new-routing-mark=\
"Out MTS" passthrough=yes per-connection-classifier=\
both-addresses-and-ports:2/0
add action=mark-routing chain=prerouting comment="LAN load balancing 2-1" \
dst-address-type=!local in-interface=ether3 new-routing-mark=\
"Avant Telecom" passthrough=yes per-connection-classifier=\
both-addresses-and-ports:2/1
Все работает, кроме VPN. Прошу помощи - не понимаю в чем проблема. Вроде пакеты приходят и уходят через одного провайдера. Это не должно рушить VPN. Либо как исключить из балансинга VPN?

Спасибо!
P.S. Без балансинга у меня все круто работает на обоих провайдерах. И отказоустойчивость тоже :)
P.P.S. VPN у меня сделан на OVPN