Почему они не пингуются и может это быть причиной что не работает маршрутизация между VLAN?
Код: Выделить всё
/interface wireless
set [ find default-name=wlan1 ] ssid=MikroTik
/interface vlan
add interface=VLAN name=vlan10MGMT vlan-id=10
add interface=VLAN name=vlan20 vlan-id=20
add interface=VLAN name=vlan30 vlan-id=30
add interface=VLAN name=vlan40 vlan-id=40
/interface ethernet switch port
set 0 vlan-header=add-if-missing vlan-mode=secure
set 1 vlan-header=add-if-missing vlan-mode=secure
set 4 vlan-mode=secure
/interface wireless security-profiles
set [ find default=yes ] supplicant-identity=MikroTik
/ip pool
add name=VLAN10 ranges=192.168.10.10-192.168.10.100
add name=VLAN20 ranges=192.168.20.10-192.168.20.100
add name=VLAN30 ranges=192.168.30.10-192.168.30.100
add name=VLAN40 ranges=192.168.40.10-192.168.40.100
/ip dhcp-server
add address-pool=VLAN10 disabled=no interface=vlan10MGMT name=VLAN10
add address-pool=VLAN20 disabled=no interface=vlan20 name=VLAN20
add address-pool=VLAN30 disabled=no interface=vlan30 name=VLAN30
add address-pool=VLAN40 disabled=no interface=vlan40 name=VLAN40
/interface bridge port
add bridge=VLAN interface=ether1
add bridge=VLAN interface=ether2
/interface bridge settings
set use-ip-firewall=yes use-ip-firewall-for-vlan=yes
/interface ethernet switch vlan
add ports=ether1,ether2,switch1-cpu switch=switch1 vlan-id=10
add ports=ether1,ether2,switch1-cpu switch=switch1 vlan-id=20
add ports=ether1,ether2,switch1-cpu switch=switch1 vlan-id=30
add ports=ether1,ether2,switch1-cpu switch=switch1 vlan-id=40
/ip address
add address=192.168.10.1 interface=vlan10MGMT network=192.168.10.0
add address=192.168.20.1 interface=vlan20 network=192.168.20.0
add address=192.168.30.1 interface=vlan30 network=192.168.30.0
add address=192.168.40.1 interface=vlan40 network=192.168.40.0
/ip dhcp-server network
add address=192.168.10.0/24 gateway=192.168.10.1
add address=192.168.20.0/24 gateway=192.168.20.1
add address=192.168.30.0/24 gateway=192.168.30.1
add address=192.168.40.0/24 gateway=192.168.40.1
/ip firewall filter
add action=accept chain=forward dst-address=192.168.20.100 src-address=\
192.168.10.99
add action=accept chain=forward dst-address=192.168.10.99 src-address=\
192.168.20.100